Goodbye Lucas Ignition

Lucas ignition module, coil, and relocation kit.

This week was the last week I will use Lucas Ignition parts. If you are a regular reader of my blog you will remember that I recently updated all my ignition parts to correct some poor performance and rough running. I’ve had a few run-ins with Lucas the Prince of Darkness…

Ignition Coil Strikes Again
Bad Fuel? Nope…

I’d forgotten how many times my ignition either through a bad coil or ignition module or both had left me stranded. Last week it did it again. The symptoms are all to obvious now.

  • The engine seems to misfire at speed.
  • The idle is rough. Frequent misfires.
  • Engine cranks but does not fire.

As I was lamenting this with JagGuy he said, “Why don’t you swap it for a basic General Motors (GM) EMI ignition. That’s what’s in all the Jaguars. It would be simple.” Simple for him for sure. And in the end not terrible at all.

JagGuy said it would be easy and it was. I called him on Wednesday night when Mr. Fisher and I were swapping ignition bits to try and find the issue. On Thursday afternoon he told me to come by after work and there it was a new module.

The fun part was how he sourced the parts. The ignition module is from a 1978 Chevy Silverado, the coil comes from a 1988 Chevy, and the bracket comes from a 1998 Chevy Caprice.

The actual part numbers from O’Reilly’s

  • BWD – CBE4P – 26.99$(US)
  • MPI – 2-5198 – 22.99$(US)

For that price…a lifetime warranty. Where is Lucas’s lifetime warranty? LIFETIME WARRANTY. And even better they are available at any O’Reilly’s or AutoZone in America. Probably in-stock, in the store.

The wiring is pretty simple.

Here it is mounted in the engine bay.

You can find a diagram pretty much anywhere on line. The only tricky part was getting the two wires that go to the distributor correct. Initially we had them switched. If you happen to do this you may notice the idle RPM to be somewhere around 1200.

I need to zip tie the leads down a bit more. I don’t like them wiggling around. We shortened the pink wire that goes to the wire coming off the clear-ish octopus like plug just below the air filter.
When we had it installed initially the idle was terrible and it caused several Code 44’s. I got those cleared by disconnecting the battery for a minute or so. They say you can disconnect the serial cable to the display, but I’ve never had any luck with that.

After I drove her to Edmond for the new tires and up to JagGuy’s shoppe for him to go over her to find the issue with the idling. When I pulled up she was running like a top. Apparently the computer starts learning after you clear the codes and run a fun cycle without any codes. By the time I drove her home she was running like a top.

On the Difficulty Scale this is a two. The assembly is easy, getting the wires hooked up is a bit of fun but not ridiculous.

Thanks goes out to JagGuy. I really appreciate your expertise and your amazing abilities.

Thanks for reading and Happy Rovering.

2 thoughts on “Goodbye Lucas Ignition

I love to hear from my readers, leave a reply

%d bloggers like this: