July 8th, 2003

July 8, 2003
As I stated in my last entry I had a nasty tick, tick, tick sound coming from under the hood.
Well I finally snuck out of my housework on Sunday to look at it. In between a load of laundry
and a messy bathroom I ventured out the laundry room door into the garage and out to the truck. I was not spotted in my slippery move to investigate the ticky sound. I crawled under the truck dragging my pony tail in some lovely filth and oil to find that I was 2 missing nuts on my driver’s side exhaust. So I got two more and tightened it back up and the noise is no more. I checked the passenger side of the engine and there was one missing over there. So I replaced the missing nut over there too.

If I had not been so lazy I could have gotten that fixed much sooner. I was so happy with myself
that when a friend came down to borrow a wrench just as I was finishing I went four doors down and helped him replace his waterpump on his GM Suburban. It was pretty easy after we got the fan off. This is his second waterpump in two years. My neighbor next door replaced his second water pump in two years also this last month. What is it with GM vehicles and bad water pumps?

Technical note. The Ditchfinder recommended that I get copper nuts for the exhaust instead of steel. Apparently Volkswagon uses copper to secure their exhaust and the copper nuts do not rust or corode (as much?). I asked him where I would find such things as I have never seen them in my lifetime. He is convinced they are readily available and very low cost. I think I will keep an eye out for them.

I love to hear from my readers, leave a reply

%d bloggers like this: